HOW TO FIX LOCALHOST AND PHPMYADMIN NOT OPENED WITH XAMPP

      37

before I can access localhost/phpmyadmin/ but today when I"m trying khổng lồ access this page I got weird page

also I can access localhost/xampp/ without any problem

Question:

How can I solve this problem ?


*

*

what you need to vày is to địa chỉ phpmyadmin khổng lồ the apache configuration:

sudo nano /etc/apache2/apache2.confAdd the phpmyadmin config lớn the file:

Include /etc/phpmyadmin/apache.confthen restart apache:

sudo service apache2 restartOn windows, I think you can just navigate lớn the apache2 config file and include the phpmyadmin config file as shown above, then restart apache


*

*

A cleaner way is lớn create the new configuration file:

/etc/apache2/conf-available/phpmyadmin.confand write the following in it:

Include /etc/phpmyadmin/apache.confthen, soft link the tệp tin to the directory /etc/apache2/conf-enabled:

sudo ln -s /etc/apache2/conf-available/phpmyadmin.conf /etc/apache2/conf-enabled

*

You should use localhost:portnumber/phpmyadminHere the Portnumber is the number which you set for your web hệ thống or if you have not mix it until now it is by mặc định - 80.

Bạn đang xem: How to fix localhost and phpmyadmin not opened with xampp


Make sure that both apache webserver và MySQL hệ thống are running. I had the same failure because I forgot lớn start my webserver.


when you run Xampp, check the apache port no. Ex: if it is displaying port 80, then type

http://localhost:80/phpmyadmin/After that it will display automatically

http://localhost/phpmyadmin/


I am using Linux Mint :After installing LAMP along with PhpMyAdmin, I linked both the configuration files of Apache và PhpMyAdmin. It did the trick. Following are the commands.

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.confsudo /etc/init.d/apache2 reload


It generally occurs when your default port for localhost is being used by another application (like apache tomcat). Easy fix is to lớn stop the application và simply go to localhost/phpmyadmin.

In my case it worked after stopping apache tomcat.


Based on your output, one of your plugins is messing up with the phpmyadmin. Try disabling all plugins khổng lồ see if that works.

If it does, enable them one by one and check again, khổng lồ find the problematic one.


Resolving same problem on Ubuntu 14.04, I use code:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-enabled/phpmyadmin.conf sudo /etc/init.d/apache2 reloadit is because since Ubuntu 13, Apache loads configuration files from the /etc/apache2/conf-enabled directory.

Ubuntu Documentation


You need reload the server.

Xem thêm: Hướng Dẫn Cài Đặt Đột Kích Phiên Bản Mới Từ Vtc Online Đơn Giản

If you use apache serversystemctl reload apache2

If you use nginx serversystemctl reload nginx


Judging by the output đầu ra of the image which you linked in one of your comments:

http://imageshack.us/photo/my-images/638/erroruh.png/

... Maybe you accidentally downloaded some form of the trang web from where you thought you were downloading phpMyAdmin. The text contains references to lớn "Dropbox" which makes me think that the information displaying is in no way related lớn phpmyadmin.

Try re-installing and see if that helps...

http://www.phpmyadmin.net


Or it could be that Skype is running on the same port (it does by default).

Disable Skype or configure Skype to use another port


I also faced the same issue. I worked on it & found out ,this is simply because i have mistakenly moved my "phpmyadmin" thư mục in to a some thư mục inside Xampp. Go through all the other folders which are inside the main "XAMPP" folder. Then if you find the "phpmyadmin" inside another folder other than "xampp" move it back lớn the main "XAmpp" folder and refresh the page. :)


A cleaner way to include the phpmyadmin config into apache2 is lớn create a new config tệp tin by:

sudo nano /etc/apache2/conf-enabled/phpmyadmin.confand write in it:

Include /etc/phpmyadmin/apache.conf
Run the Apache server, chú ý down the port number(eg:8081)Open your browser và type localhost:8081(or apache"s port number)


Just change - $cfg<"Servers"><$i><"host"> = "localhost"; in config.inc.ph. I.e. From existing to lớn localhost if you installed it locally


Make sure you still have phpMyAdmin maybe you deleted it in your htdocs folder?

Get the latest version: http://www.phpmyadmin.net/home_page/downloads.php

Unzip then place the phpMyAdmin (rename the thư mục if it has version numbers) in your htdocs folder.

Make sure Skype is disabled as it will some times run on the same port as your XAMPP install... I"m not sure why but apache installed via xampp on some windows 7 machines ive seen apache not run if skype is on after 10years of IT work.

So make sure apache is running, mysql is running và hit:

localhost/phpMyAdmin

You should get some kind of install prompt. Step through this you will learn lots along the way. But basically its one config file that needs some settings.


chia sẻ
Follow
answered Nov 21, 2013 at 22:58
Dan CarterDan Carter
20133 silver badges1212 bronze badges
địa chỉ a phản hồi |
-1
I had the same problem. Couldn"t access http://localhost/joomla neither.and I did not quite understand the other answers.The simple solution for me:

stop all actions in xampp (I had apache and mysql running. Apache on port 80 and 7000something)quit firefoxrestart the actions (apache & mysql) restart firefox.open http://localhost/phpmyadmin (or http://localhost/joomla - whatever it be)voila!

Now apache runs on port 80 & 443 & mysql on 3306.


tóm tắt
Follow
edited Sep 18, năm ngoái at 17:25
answered Sep 18, năm ngoái at 14:00
einserpascheinserpasch
933 bronze badges
showroom a bình luận |
-1
What you need to bởi is to địa chỉ phpmyadmin lớn the apache configuration:⠀⠀⠀⠀⠀⠀⠀

sudo nano /etc/apache2/apache2.confAdd the phpmyadmin config to the file:

Include /etc/phpmyadmin/apache.confThen restart apache:

sudo service apache2 restartOn ubuntu 18.0.1, I think you can just navigate to lớn the apache2 config file & include the phpmyadmin config file as shown above, then restart apache

http://127.0.0.1/phpmyadmin/


share
Follow
edited Jun 28, 2020 at 17:20
CommunityBot
111 silver badge
answered Jan 7, 2020 at 13:12
JavedJaved
34722 silver badges55 bronze badges
1
showroom a bình luận |
Highly active question. Earn 10 reputation (not counting the association bonus) in order lớn answer this question. The reputation requirement helps protect this question from spam & non-answer activity.

Not the answer you're looking for? Browse other questions tagged php phpmyadmin or ask your own question.


The Overflow Blog
Featured on Meta
Linked
4
Can't access to phpmyadmin in XAMPP
0
Can't access localhost/phpmyadmin on Ubuntu 14.04
Related
1264
Enumerations on PHP
1231
Secure hash và salt for PHP passwords
350
Setting up foreign keys in phpMyAdmin?
4895
Reference — What does this symbol mean in PHP?
1319
"Notice: Undefined variable", "Notice: Undefined index", "Warning: Undefined array key", & "Notice: Undefined offset" using PHP
2194
How does PHP 'foreach' actually work?
552
ERROR 2002 (HY000): Can't connect to lớn local MySQL vps through socket '/var/run/mysqld/mysqld.sock' (2)
1229
Reference - What does this error mean in PHP?
279
How lớn configure XAMPP to lớn send mail from localhost?
Hot Network Questions more hot questions
Question feed
Subscribe to RSS
Question feed to lớn subscribe to lớn this RSS feed, copy & paste this URL into your RSS reader.


lang-php
Stack Overflow
Products
Company
Stack Exchange Network
site kiến thiết / hình ảnh © 2022 Stack Exchange Inc; user contributions licensed under cc by-sa. Rev2022.3.24.41762


Stack Overflow works best with JavaScript enabled
*

Your privacy

By clicking “Accept all cookies”, you agree Stack Exchange can store cookies on your device & disclose information in accordance with our Cookie Policy.